Jump to content

Excel


 Share

Recommended Posts

J'ai un classeur avec deux feuilles.

J'aimerais réunir en une seule les données des deux.

 

Pour simplifier disons une feuille "Adresse" et une autre "Tél", j'aimerais voir apparaître TOUS les individus des répertoires avec les données Adresse et/ou Tél.

- Peut-on faire ça sans macro ?

- Sinon, comment faire ?

 

Merci d'avance.

Link to comment
Share on other sites

Tes listes de nom sont exactement les memes sur tes 2 feuilles?

Bien sûr que non, ce serait trop simple de compléter une liste avec l'autre. Mais il y a des noms en commun.

 

 

En fait, cela ressemblerait plutôt à

 

Poste Période Achats

A 1 12

B 1 3

B 2 1

 

et

 

Poste Période Ventes

A 1 11

B 1 1

C 1 14

 

Et je voudrais avoir

 

Poste Période Achats Ventes

A 1 12 11

B 1 3 1

B 2 1 0

C 1 0 14

Link to comment
Share on other sites

Si tes deux feuilles sont triées par "poste" il est possible de récupérer les données "ventes" avec la fonction "recherchev". Mais cette fonction ne te permettra pas de récupérer des données pour lesquelles il n'y a pas d'entrées dans la colonne "poste" (dans ton exemple le poste C).

Link to comment
Share on other sites

1° nouvelle feuille "Recap"

2° Copier les 2 premieres colonnes de "Poste Période Achats"=PPA

coller dans "Recap"

A 1

B 1

B 2

 

3° Copier les 2 premieres colonnes de "Poste Période Ventes"=PPV

coller dans "Recap" sous l'existant

A 1

B 1

B 2

A 1

B 1

C 1

 

4° trier toute la feuille recap par colonne A et B

5° Supprimer "a la main" les boublons ( B1, A1 ..)

A 1

B 1

B 2

C 1

 

Devant chacun des trois tableaux ajouter une colonne =B1&C1

"PPA" devient

A1 A 1

B1 B 1

B2 B 2

 

"Recap" devient

A1 A 1

B1 B 1

B2 B 2

C1 C 1

 

6° Ajouter sur derniere colonne la formule:

=SI(ESTNA(RECHERCHEV(A1;PPA!$A$1:$D$30;4;FAUX))

;0

;RECHERCHEV(A1;PPA!$A$1:$D$30;4;FAUX))

 

7° Ajouter sur derniere colonne la formule:

=SI(ESTNA(RECHERCHEV(A1;PPV!$A$1:$D$30;4;FAUX))

;0

;RECHERCHEV(A1;PPV!$A$1:$D$30;4;FAUX))

8 Fini :coolspot:

 

Edit : Ca te convient ou tu voulais 1 seule formule pour faire le tout ?

Link to comment
Share on other sites

2° Soluce entierement sans manip ( uniquement formules)

 

1° Nouvelle feuille "Recap"

En colonne A =PPA!A1&B1

En colonne B =PPA!C1

A1 12

B1 3

B2 1

 

En colonne C =PPV!A1&B1

En colonne D =PPV!C1

(Etirer chacune des formules)

A1 12 A1 11

B1 3 B1 1

B2 1 C1 14

 

3° Tableau intermédiaire ( elimination des doublon A1, B1, ..)

En F1 =A1

En F2 =SI(ESTNUM(TROUVE(A2;F1;1));F1;F1& ":" &A2)

(Etirer la formule de F2)

 

A1 12 A1 11 A1

B1 3 B1 1 A1:B1

B2 1 C1 14 A1:B1:B2

 

4° Fin tableau intermédiaire ( elimination des doublon A1, B1, ..)

En G1 =Fx ( ou x est la DERNIERE ligne de F)

En G2 =SI(ESTNUM(TROUVE(C2;G1;1));G1;G1& ":" &C2)

(Etirer la formule de F2)

 

A1 12 A1 11 A1 A1:B1:B2

B1 3 B1 1 A1:B1 A1:B1:B2

B2 1 C1 14 A1:B1:B2 A1:B1:B2:C1

 

 

5° Tableau de récap

I1 = Gx ( x est la DERNIERE logne de G)

I2 = 2

I3 = I2+3

Etirer I3 vers le bas

 

J2 = =STXT(I$1;I2;2)

 

K2 = =SI(ESTNA(RECHERCHEV($J2;$A$1:$B$1000;2;FAUX));0;RECHERCHEV($J2;$A$1:$B$1000;2;FAUX))

 

L2 = =SI(ESTNA(RECHERCHEV($J2;$C$1:$B$1000;2;FAUX));0;RECHERCHEV($J2;$C$1:$B$1000;2;FAUX))

 

6° Etirer I2, J2, K2, L2 vers le bas

 

Fini :coolspot: :coolspot:

 

Tu veux pas un mail ? :lol:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...